Showing 3 reviews for Axxess AX-AGL610

Customer Review Summary for Axxess AX-AGL610
Average Customer Rating is 4.5 out of 5 stars:
4.5
based on 6 Reviews
Share your thoughts with others:
Rating Distribution:
5 star:
.
.
50%
4 star:
.
.
50%
3 star:
.
0%
2 star:
.
0%
1 star:
.
0%
what's this?
Average Attributes Rating:
Durability
4.2
Value
4.7
Features
4.5
Design
4.8
Usability
5.0
what's this?
Most Helpful 4 star Customer Reviews:
April 12, 2013 Works as expected
Review by
Kyle from Gilbert, AZ
Overall
Durability
Value
Features
Design
Usability
Purchased this item to reduce electronic whine in my car speakers while listening to my iPod. Worked as expected and was easy to install. A con would be the quality of the cables to the isolator box. After a while where the cables connected to the quick connectors started failing and would periodically cut out. This, in part, was due to how I installed it but would like to see these connections be made a little more sturdy.
Help other customers find the most helpful reviews
Was this review helpful to you?
Report Abuse | Write a Review
Share on Facebook Share on Twitter Share on Delicious Share on Buzz
November 10, 2012 Ok
Review by
Tim from New Florence, PA
Overall
Durability
Value
Features
Design
Usability
this was the first noise filter that i have ever bought. i got it because i had an whine that increased with the RPM of the motor and there was a hiss coming from the sub par head unit i have. this took care of about 75 % of the sound but when it is played at high volumes you can still hear the unwanted noises
Help other customers find the most helpful reviews
Was this review helpful to you?
Report Abuse | Write a Review
Share on Facebook Share on Twitter Share on Delicious Share on Buzz
October 14, 2012 Axxess AX-AGL610
Review by
bdavey313 from Detroit MI
Overall
Durability
Value
Features
Design
Usability
I bought these noise filters do to a buzzing in speakers and alternator whine. I've never owned any b4 and these are my first. Had them hooked up and alternator whine was gone and buzzing wasn't as noticeable. After a month i think i cooked the inside of them because everything came back. I have two for each amp. 4 ch powerbass600w and 1 ch planetaudio 4000w. I like my music loud so maybe they couldn't handle it.
Help other customers find the most helpful reviews
Was this review helpful to you?
Report Abuse | Write a Review
Share on Facebook Share on Twitter Share on Delicious Share on Buzz