Showing 5 reviews for SoundStorm EV4.400

Customer Review Summary for SoundStorm EV4.400
Average Customer Rating is 3.2 out of 5 stars:
3.2
based on 5 Reviews
Share your thoughts with others:
Rating Distribution:
5 star:
.
.
40%
4 star:
.
.
20%
3 star:
.
0%
2 star:
.
0%
1 star:
.
.
40%
what's this?
Average Attributes Rating:
Durability
3.2
Value
3.2
Features
3.2
Design
4.2
Usability
3.4
what's this?
Quick Comparison:
Most Helpful Customer Reviews:
September 17, 2013 Great Buy.
Review by
Festus from Piketon, Ohio
Overall
Durability
Value
Features
Design
Usability
I put this EV4.400 in a single cab Toyota pickup with an Alpine head and speakers. It provides every thing I expected and more. Plenty of power and a clear sound. 100% satisfied.
Help other customers find the most helpful reviews
Was this review helpful to you?
Report Abuse | Write a Review
Share on Facebook Share on Twitter Share on Delicious Share on Buzz
July 26, 2013 Horrible
Review by
Tom from Milton, PA
Overall
Durability
Value
Features
Design
Usability
This amp produces horrible alternator noise, that varies with engine RPM, at 0 volume. I finally figured out that it was the amp after eliminating other potential noise sources such as the other amp, RCA cables, and bad ground. Do not buy. Some of the other reviews mention this as well.
Help other customers find the most helpful reviews
Was this review helpful to you?
Report Abuse | Write a Review
Share on Facebook Share on Twitter Share on Delicious Share on Buzz
June 15, 2012 SoundStorm EV4.400
Review by
cgcustoms from saddle brook, nj
Overall
Durability
Value
Features
Design
Usability
The SoundStorm puts out a good sound, and is definitely worth the money.
Help other customers find the most helpful reviews
Was this review helpful to you?
Report Abuse | Write a Review
Share on Facebook Share on Twitter Share on Delicious Share on Buzz
October 17, 2011 Total waste
Review by
Bob from Alamogordo, NM
Overall
Durability
Value
Features
Design
Usability
Complete waste of time and money! I bought this to replace another soundstorm that came defective from the factory. The power light stays on all the time, even if I disconnect the remote wire. The amp feels hot when it should be off. When it is activated via the remote it makes a big pop or boom and then starts hissing. When the engine is on there is a terrible ignition noise. To make sure it wasn't a problem with the wiring or install I put my Audiopipe amp in the same location with all the same wiring and it sounded beautiful.
Help other customers find the most helpful reviews
Was this review helpful to you?
Report Abuse | Write a Review
Share on Facebook Share on Twitter Share on Delicious Share on Buzz
October 10, 2011 Very nice
Review by
tony from delaware, OH
Overall
Durability
Value
Features
Design
Usability
I've owned the other ssl amp and i had it for a year and its still kicking.. i ordered a new one bc my warranty was up and i got to say this amp performs just like the other one.. tons of power and clarity. I like the desgin on this model better.. so for 50 bucks get it if you want it to push some door speakers. i have it pushin 4 door speakers and 2 teetwers. Each set of door speakers is running in parallel to get a 2 ohm load so the first and second channel is used for my door speakers and the 3rd and 4th is for my tweeters.. this amp is 2 ohm stable btw.
Help other customers find the most helpful reviews
Was this review helpful to you?
Report Abuse | Write a Review
Share on Facebook Share on Twitter Share on Delicious Share on Buzz